Excel 2007: Basics

» Opening Excel

Open Excel by double-clicking on the desktop icon (or single-click &
ﬁ press Enter on the keyboard). Or use Start>All Programs>Microsoft
Microsoft Office>Excel or some combination of menus & sub-menus.
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Close the spreadsheet by clicking on the X below these buttons.

» Characteristics of a Worksheet

e A cell can contain up to 32,767 characters, but column width is only 255 characters.
e A worksheet can contain up to 1,048,576 rows and up to 16,384 columns.
e The number of worksheets in a workbook is restricted by available memory of the computer.

» Editing
e When you open a new workbook, the cell Al is active in the first worksheet. You can start
typing in that cell right away or you can move to another cell. You can use the arrow keys or
the mouse to select a cell.
e Press Enter or leave the cell to put the information into the computer's memory.

e You can use the Undo button [- to undo the last 16 actions in your worksheet.

» Using the keyboard to move to a new cell

Press the Enter button if you want to type in the cell below.
Press the Tab key if you want to type in the cell to the right.
Use Shft+Tab if you want to type in the cell to the left.

Use Shft+Enter if you want to type in the cell above.

You can edit individual characters in a cell by double-clicking the cell and selecting individual
characters to edit. Using these buttons will allow you to move within the cell.

Home Moves the insertion point to the beginning of the cell entry.

End Moves the insertion point to the end of the cell entry.

Right (—) Moves the insertion point one character to the right in the cell
entry.

Left («) Moves the insertion point one character to the left in the cell
entry.

Backspace Deletes characters or selected text to the left of the insertion
point.

Delete Deletes characters or selected text to the right of the
insertion point.




> Formatting Numbers

When formatting numbers in a cell or range, you can choose many categories. The default option is
usually General. If you are typing dates & don'’t like the way that Excel is changing them, use the
Date category to choose the correct method for the document. If Excel is treating an alphanumeric
phrase as a mathematical expression or a date, use the Text category to keep the alphanumeric
entry exactly as you typed it.
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Click the Home tab, look for Number section
e The “Dollar Sign” button will change the number to a currency style with a dollar sign to the left,
separated 1,000’s with a comma, & 2 decimal places.
e The “Percent” button will display the value as a percentage with 0 decimal places.
e The “Comma” button will display the value with 1,000’s separated by a comma & 2 decimal
places.
e The next 2 buttons will either increase or decrease the number of decimal places.

> Formatting Cells

Each cell can be changed individually or as part of a group.
e Select the cell or range of cells.
e Use Home Tab and choose among several groups—Number, Alignment, Font, Border,
Patterns, & Protection.

» Under the Font tab, you can:

e Choose to change the font type and size. 1

e Choose have text or numbers shown in bold, italic, or Blue, J.
underlined.

e Choose to have characters shown as superscript, subscript, or Brown, N{)
strikethrough. GreenT

e Choose a color for the characters in the cell. B o

» Format Painter

You can quickly copy formats between cells and objects.
e Select the cell that has the desired formatting.
e Click on the Format Painter (once to paint once, double-click to keep the Format Painter on).
Notice that the mouse cursor has turned into a paintbrush and white plus sign.
e Paint by holding down the left mouse button & clicking into an individual cell or dragging
through many cells.
e To release the paintbrush, click on the Format Painter once.




> Changing Column Width and Row Height

e If you see a row of pound signs (######) in the cell, the column is not wide enough to display
the numerical value contained in that cell. To change the column width, use
Home>Cells>Format>Autofit Column Width which adjusts the width of the column to the widest
entry. (If you add other entries later, the width may need to be readjusted.)

e To change the row height, use Home>Cells>Format>Autofit Row Height to adjust the height of
the row to the tallest entry. (If you add other entries later, the height may need to be adjusted.)

» Under the Alignment tab, you Format Cells 2IX
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> AutoComplete

When you are typing text in a cell, AutoComplete suggests a matching item from another cell in the

column once you have typed enough letters to identify it. Right-clicking and using Pick From Drop-
down List gives similar results. If AutoComplete is not working, use Click on Office Button in upper
left hand corner>Excel Options>Advanced

> AutoFill

Once you type one, two, or more cells that contain the basis for a series, select the cells and then
drag the AutoFill handle—the black square that appears at the lower-right corner of the last cell
selected—to show AutoFill the range of cells you want to fill with the series of data. AutoFill analyzes
the starting cells, determines what the contents of the other cells should be, and enters the
information automatically.

To make a custom list, use Office Button>Excel Options>Popular and choose the Edit Custom
Lists button.
e Select NEW LIST.
Start typing the new list in the List entries: box. Press the Enter key after each item.
Click on the Add button to add the list to the Custom Lists box.
If you want to edit the list, click on the list and edit in the List entries: box.
If you want to delete the list, click on the list and click on the Delete button. Click OK to the
message about permanently deleting the list.



e Click OK to get out of the dialog box.
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> AutoCorrect

This feature corrects common spelling errors as you type text into a cell. This option is found in Office
Button>Excel Options >Proofing> AutoCorrect Options. Choose what you would like to be
automatically corrected while you type.

If you have a long phrase or title that you type on a regular basis, you can also use the “Replace text
as you type” feature.
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> Merge and Center

Z:E If you want a title to go across several columns, type the title in the left cell.
Select all the cells that include the distance for the title. Click on the
Home>Merge & Center

Notice that in this example cell Al is now enlarged to a width of 5 columns & the text is centered.
(When you merge cells, the cells to the right of the first one, Cells B1, C1, D1, & E1, are
inaccessible.)
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» Sorting

Excel provides database-sorting capacity. If there are rows of information, data can be sorted based
on a certain column heading and the row information will stay together. For example, if there was a
list of employees and you wanted to sort the list by birth dates, you could click anywhere in the
Birthdate column, click Home>Sort & Filter

Use Custom Sort to have more choices about sorting. If the list starts with a header row, the list can
be sorted by the Header row name.

Here are the rules for sorting in ascending order. The rules for sorting in descending order are
reversed for the first 3 rules.
e Numbers are sorted from the smallest negative number to the largest positive number.
e Dates and times are sorted based on their underlying value.
e Text and text that includes numbers is sorted as follows: 0123456789 (space) ! "#$ % &
‘O *+,-.1:;<=>2@[\]*_"{|}~ABCDEFGHIJKLMNOPQRSTUVWXY
z

e All error values are equal and are not sorted.
e Blanks are always sorted last.

» Under the Border tab, you can:
e Choose where on the spreadsheet to have the border or lines outlining a specific area.
e Change the style and color.
e The changes can be effective for a single cell or a range of cells, depending on what is
highlighted at the time.



» Under the Patterns tab, you can:
e Choose among options filling the cell’'s background.

Choose a pattern and/or color.
G D

» Under the Protection tab, you can:
e Choose to keep certain cells locked or hidden.
e This is only effective when the spreadsheet itself has protection.

» Finding and Replacing Information

e You can use Home>Find & Select>Find or Replace. Either will get you to the Find and Replace

dialog box.
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e In Find what, type the word, phrase, or number you are seeking. A question mark (?) matches
any single character. An asterisk (*) matches any string of characters.

e In the Replace with, type what you want instead of what is found. If you leave this box blank, it

will clear the phrase in the Find What box.

In Within, choose Sheet or Workbook

In Search, choose columns or rows. Searching by columns is usually faster.

In Look in, choose formulas or values.

Use Match case when you want to distinguish between uppercase and lowercase characters.

Use Match entire cells only when you want to search for an exact and complete match of

characters specified in the Find what text box. If this option is not selected, the Find feature will

locate partial information.

e Click Find All to see a list of all incidents.

e Click Find Next to find the first or next incident in the table.

e Use Replace All if you want all incidents changed. Use Replace if you want to change each
incident separately.



> Inserting Comments: To insert a comment about a cell, click on the cell. Use Review>New
Comment and type the information in the box. (You can delete the name posted at the beginning
of the note.) Click in another cell to close the comment. Notice that there is a red mark in the
upper right of the cell with the comment. Once a comment has been created, it can be modified.
To change the comment text, right-click on the cell and use Edit Comment. Make changes in the
comment box. To remove comment, right-click on the cell and use Delete Comment. To have the
comment continually showing, right-click on the cell and use Show Comment. To hide the
comment, right-click on the cell and use Hide Comment.
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To print comments, use Page Layout>Page Setup>Print Titles. In the “Print Comments:” area, click
on the drop-down arrow and choose “At end of sheet” or “As displayed on sheet.”

» AutoCalculate
Select a range of cells, in the status bar view the total value of the range of cells that are selected. If
you do not see the value, right click on the status bar and choose what you want to see.
e Values are Average, Count (Entries in Cells), Count Numbers, Maximum, Minimum, and
Sum.

> AutoSum

After selecting a range of cells and clicking the AutoSum button, the calculation required to arrive at
the sum is automatically entered into a nearby cell. You can also choose a cell and click the
AutoSum button. If the AutoSum function guesses the wrong cells you want added, you can correct
it by selecting different cells.

e Select a range of cells.

e Click the Formula tab>AutoSum button. The total value shows up in a nearby cell.

Or

e Place the cursor in a cell near a range of numbers.

e Click the Formula tab>AutoSum button.

e If the AutoSum function is incorrect, go to the correct cells.

e Hold down the left mouse button to drag and select the correct range.
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> Printing Multiple Sheets with Repeated Row or Column

If you have information over multiple sheets and you want to keep track of information in the top row
or left column, you can have that row or column repeated on every printed page.

Use Page Layout>Page Setup>Print Titles. Depending on whether a row or column is needed, click
on the box at the right of that entry box.
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Click on the row or column needed. It is usually the first row or the first column. Click on the box at
the right again. Click on Print Preview to see if the information is accurate. Then click on Print or OK.

» Adding More Worksheets

You can add more worksheets by right-clicking on the worksheet’s tab and choosing
Insert>Worksheet.

» You can change the name of your worksheet by right-clicking on the worksheet’s tab and
choosing Rename. Worksheet names:

e Can be up to 31 characters in length.

e Cannot contain colons, slash marks, backslashes, question marks, or asterisks.
e Cannot be enclosed in square brackets.

e Cannot be the same as another sheet in the group.



